• Must speak and understand English.
  • Must have an Android (Android 5 plus or more) or iOS phone (iPhone 5 or higher) or Ipad or Android Tablet to install the app
  • Able to do basic movements and will require kneeling/ sitting on the floor.
Go to top